Resolved
The issue has been solved.
Monitoring
The fix is deployed, and we are monitoring it.
Identified
The VAMSYS push might create duplicate entries on VAMSYS at the moment when updating the routes via the VAMSYS Sync page. The selective push is working correctly. We're working on a fix.