Pilots are unable to register to Pilot Portal
Resolved·Partial outage

The issue has been solved.

Mon, Jan 5, 2026, 02:18 AM
(2 weeks ago)
·
Affected components
Pilot Portal
Updates

Resolved

The issue has been solved.

Mon, Jan 5, 2026, 02:18 AM

Monitoring

The issue should be fixed.

Sun, Jan 4, 2026, 11:41 PM(2 hours earlier)

Monitoring

Users who are unable to sign up should try reloading the page to see if the issue persists.

Sun, Jan 4, 2026, 10:44 PM(56 minutes earlier)

Monitoring

The fix has been deployed, and we're monitoring the services.

Sun, Jan 4, 2026, 10:41 PM

Identified

We've identified issues that block pilots from registering for the airline pilot portal. The fix is in progress and should be deployed any minute.

Sun, Jan 4, 2026, 09:10 PM(1 hour earlier)