Back to overview
Degraded
Admin App is down
May 20, 2026 at 10:07pm UTC
Affected services
Admin App
Resolved
May 20, 2026 at 10:13pm UTC
Admin App recovered.
Affected services
Created
May 20, 2026 at 10:07pm UTC
Admin App is degraded.
Affected services